Back to overview
Downtime

Temporary access issues due to Cloudflare outage

Nov 18, 2025 at 12:55pm UTC
Affected services
Freelancehunt.com
Freelancehunt blogs

Resolved
Nov 18, 2025 at 3:05pm UTC

All systems have been restored and are now operating normally.

Updated
Nov 18, 2025 at 1:09pm UTC

Cloudflare is working on restoring service. We apologize for the inconvenience and appreciate your patience.

Created
Nov 18, 2025 at 12:55pm UTC